WatchDirectory Forum
http://www.watchdirectory.net/cgi-bin/yabb25/YaBB.pl
watchDirectory forums >> Bug Reports >> Play a sound / Wav  
http://www.watchdirectory.net/cgi-bin/yabb25/YaBB.pl?num=1162978988

Message started by bemarv on Nov 8th, 2006 at 10:43am

Title: Play a sound / Wav  
Post by bemarv on Nov 8th, 2006 at 10:43am
When I try to create a new task via the 'automatically play a sound....'  the program does nothing, no screen appears so I can't enter any wav file.

For all the other tasks I get a new screen to put in the values.

Title: Re: Play a sound / Wav  
Post by Gert on Nov 8th, 2006 at 11:09am
Hi,

A window *should* appear for the "auto wav" plugin.
Can you please press CTRL+SHIFT+9 inside the watchDirectory Control Center. That will open Windows Explorer inside the directory where WD is installed. Now navigate to the sub-directory called Plugins. Can you check if these 2 files are present there:
wdopAutoWav.dll
wdopAutoWav.meta

Some versions of watchDirectory before the current 4.1 release didn't install the "Play a wav file" plugin, however, in that case you shouldn't be able to even select the plugin.... Are you running the latest (4.1) version? See Help -> About.

Gert

Title: Re: Play a sound / Wav  
Post by bemarv on Nov 8th, 2006 at 11:20am
I am running the latest version.
But I installed it on a 'older'  windows NT machine ( against the requirements)  , I will install it on my XP-pro pc.

Title: Re: Play a sound / Wav  
Post by Gert on Nov 8th, 2006 at 11:25am
I believe it should work on NT4 (with all service packs and the latest IE version), but I have to confess that we do not test on NT4 anymore.
Did you check for the existence of the 2 files I mentioned?

Gert

Title: Re: Play a sound / Wav  
Post by bemarv on Nov 9th, 2006 at 10:11am
The 2 files are in the directory.

I have'nt tried it on my XP-pc yet.

I installed the WDnotify on my NT4 and I work around the problem, I enabled the wdnotify for my Task and I get a sound/popup. So that's ok for me.
I have Service Pack 1 , and IE version 6.
There's no need to investigate further.
Thanks for your help

Title: Re: Play a sound / Wav  
Post by Gert on Nov 9th, 2006 at 7:37pm
Actually.... if wdNotify works (uses the same Windows API's to play sound as "Auto Sound") it makes me very curious why wdopAutoWav.dll refuses to load on NT4. Besides playing sounds, it doesn't do anything "strange" at all. I will look into this further the next few days.

Gert

Title: Re: Play a sound / Wav  
Post by Gert on Nov 10th, 2006 at 12:15pm
The attached "play wav files" dll should fix this issue on NT4.
To install:
  • Stop all your WD tasks
  • Inside the WD Control Center, press CTRL+SHIFT+9 (this opens the directory where WD is installed)
  • open the sub-directory called Plugins
  • unzip the attached zip-file (this overwrites wdopAutoWav.dll)
  • stop the WD Control Center, and start it again


Gert
http://www.watchdirectory.net/cgi-bin/yabb25/YaBB.pl?action=downloadfile;file=wdopAutoWav.zip (95 KB | )

Title: Re: Play a sound / Wav  
Post by bemarv on Nov 13th, 2006 at 10:18am
Thanks Gert,
You fixed it !  Great job !

WatchDirectory Forum » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2017. All Rights Reserved.