WatchDirectory Forum
http://www.watchdirectory.net/cgi-bin/yabb25/YaBB.pl
watchDirectory forums >> Bug Reports >> Email Failure
http://www.watchdirectory.net/cgi-bin/yabb25/YaBB.pl?num=1199275519

Message started by PieOPah on Jan 2nd, 2008 at 1:05pm

Title: Email Failure
Post by PieOPah on Jan 2nd, 2008 at 1:05pm
Hi,

I am currently using 4.5 Beta and recently found that a number of emails failed to send.

Looking at the log, I can only assume that this is due to a problem with one of the E-mail addresses

vs: LogHandle = 328
*** seeStringParam(0,53,<********@***********.com>)
*** seeIntegerParam(0,8,0)
*** seeIntegerParam(0,25,59)
*** seeSendEmail
*** Sending...
<204:540108000>
S: MAIL FROM:<********@***********.com>
<205:540108031>
R: 250 2.1.0 Sender OK
<206:540108031>
<207:540108031>
S: RCPT TO:<*****.******@***********.com>
<208:540108031>
R: 250 2.1.5 Recipient OK
<206:540108031>
<207:540108031>
S: RCPT TO:<*******.**********@***.co.za>
<208:540108031>
R: 550 5.7.1 Unable to relay
ERROR(540113046): SockCode=0 SeeCode=-49 PrevState=208 ThisState=208 NextState=208
SMTP returned error. 550 5.7.1 Unable to relay
*** seeClose
<258:540113046>
S: QUIT
<259:540113078>
R: 221 2.0.0 Service closing transmission channel
vSocket: 0 closed

Is there a way to still have the mail sent even when it encounters a problem with only one of the addresses?

In the meantime, I have removed the CC addresses and it is working okay for me!

Thanks :)

Title: Re: Email Failure
Post by Gert on Jan 2nd, 2008 at 1:37pm
Hi,

Actually, it looks like you have not setup a userid/password for the email-service. In that case it runs unauthenticated, and a lot (most?) smtp-servers don't like that. Sometimes it will work, if you have recently "checked for email" from that computer: the smtp-server will reuse the userid/password of the POP-server in that case. If the  "check for email" was too long ago, the smtp-server rejects the attempt to send email.

Does that make sense?

Gert

Title: Re: Email Failure
Post by PieOPah on Jan 2nd, 2008 at 5:26pm
Hi Gert,

What you have written makes sense however I can't understand why I am having problems.

Of the several Email tasks I have, only 1 fails (and that only recently started to fail). When I remove the CC addresses it is successful.

afaik the smtp server has no credentials - not sure of the setup, I just entered the IP address as I was given by our mail admin!

Ah well, not a problem since I really don't care about others receiving this mail, as long as I get a copy :D

Thanks anyway!

Title: Re: Email Failure
Post by Gert on Jan 3rd, 2008 at 7:28am
Also, looking at the errorlog, it seems your smtp server has trouble (not allowed) sending messages to the ***@***.co.za email address. If you use your own email-client (with the same SMTP server), can you send messages to that address?
It may also be that the server (where WD is running on) is not allowed to send messages "to the outside world". The smtp log (ask your network admin) may contain more specifics.

Gert

WatchDirectory Forum » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2017. All Rights Reserved.