WatchDirectory Forum
http://www.watchdirectory.net/cgi-bin/yabb25/YaBB.pl
watchDirectory forums >> Plugins >> FTP Plugin issue with Tags and after.filenew
http://www.watchdirectory.net/cgi-bin/yabb25/YaBB.pl?num=1216304852

Message started by bgeoghan on Jul 17th, 2008 at 4:27pm

Title: FTP Plugin issue with Tags and after.filenew
Post by bgeoghan on Jul 17th, 2008 at 4:27pm
Hello,

I'm hoping that you can help.  I am using the FTP plugin to monitor our public FTP site and then FTP across to our AS/400 system for processing.  The processing basically requires me to take the uploaded file and append it as a member to an existing AS/400 file.  

I have the Remote File set to - EDIG{eventnumber}.  

The file successfully uploads to the AS/400, however the after.filenew errors out.  Here is the  text from the after.filenew :

append %filename% FTPIN

I attached the XML output from the WD FTP conversation log.  Basically I am receiving the following message :

FTPREPLY: cmd: CWD EDIG; Code: 550; Text: 550-Specified library does not exist or cannot be accessed.

I appears that the FTP plugin is not using the {eventnumber} tag when forming the source filename  for the after.filenew append command.

Any help would be greatly appreciated.

Title: Re: FTP Plugin issue with Tags and after.filenew
Post by Gert on Jul 18th, 2008 at 10:19am
Hi,

Are you sure this message:

Quote:
FTPREPLY: cmd: CWD EDIG; Code: 550; Text: 550-Specified library does not exist or cannot be accessed.

is in response to your "after.filenew"?

WD 4.5.3 and earlier had some issues with doing extra "CWD's" (change working directory command), this should be resolved in the current 4.5.4 release.
Are you running with 4.5.4?

Gert

WatchDirectory Forum » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2017. All Rights Reserved.