WatchDirectory Forum
http://www.watchdirectory.net/cgi-bin/yabb25/YaBB.pl
watchDirectory forums >> German >> Problem beim Zippen
http://www.watchdirectory.net/cgi-bin/yabb25/YaBB.pl?num=1272973354

Message started by Backupboy on May 4th, 2010 at 1:42pm

Title: Problem beim Zippen
Post by Backupboy on May 4th, 2010 at 1:42pm
Hallo erst mal,

Bin neu hier und brauche auch gleich mal ein bischen Unterstützung
Wir nutzen WD um unter anderem in einem Unterverzeichniss Ordner bei eintreten eines Erignisses zu Zippen. (soweit der Plan)  ;)

Es sollen nur Ordner gezippt werden die nach einer sechs stelligen Zahl ein E angehangen haben (Beispiel: 001234E-Testdir) Dies habe ich durch verwendung der Platzhalter ? und * im Filter eingestellt (So : ???????E *). Dabei habe ich nach langem suchen heraus gefunden das man statt sechs mal ? als Platzhalter (sech zahlen vor dem E) sieben angeben muss. Ist das ein Programmfehler oder so gewollt ?. :o

Mein eigentliches Problem ist aber das ich gerne Alle Dateien und Unterordner mit ihren Dateien aus diesen E-Ordnern in ein einziges Zipfile gepackt hätte, was aber trotz des Updates auf 4.6.2.2 (leider englisch) irgendwie nicht richtig funktioniert. sobald ich die Option "Create ZIPS for complete directories" setze werden nicht mehr alle Unterverzeichnisse mit gepackt. Nimmt man den Haken raus werden auch die Unterverzeichnisse gepackt, aber leider habe ich einen große Menge an Zipps die durch die mitgespeicherten "Store the relative path"´s sehr kompliziert zu entpacken sind.

Gibt es keine Möglichkeit WD dazu zu bringen einfach alle Ordner mit einem "E" und darin enthaltene Unterordner (zwei, drei, Ebenen) in ein einziges Zip zu Packen ?

Hoffe Ihr könnt mir folgen und helfen...

LG
Micha  

Title: Re: Problem beim Zippen
Post by Dirk on May 4th, 2010 at 2:14pm
Hallo Micha,


Quote:
Hoffe Ihr könnt mir folgen und helfen...

Bestimmt!

Also zunächst: Die englische und deutsche Version ist immer dieselbe. Du kannst die Sprache in der Menüleiste unter "Language" beliebig oft umstellen.

Bzgl. der 7 Platzhalten habe ich das eben überprüft. Ich kann das von Dir beobachtet Verhalten nicht feststellen. Gerne kannst Du mir Deine Aufgabenkonfig und/oder Screenshots an die Adresse im Footer senden, dann schau ich mir das mal an.

Bzgl. "ZIPs für komplette Verzeichnisse erstellen, nicht nur für einzelne Dateien" erläutert die Hilfe, was genau beachtet werden muss:
http://de.watchdirectory.net/wdhelp/plugins/wdopAutoZip_deu.html

Bzgl. "Store the relative path" kannst Du das auch auf "nicht speichern" umschalten, somit werden beim Entpacken alle Dateien in ein Verzeichnis entpackt.

Ich denke mit letzterer Einstellung läuft es so, wie Du möchtest, oder?

Title: Re: Problem beim Zippen
Post by Backupboy on May 4th, 2010 at 3:30pm
Hallo Dirk,

erst mal Danke für´s schnelle Antworten

Sorry...habe zuerst die nur-englische Version erwischt, die konnte man nicht umstellen. Aber Dank deines Tipps habe ich noch mal die andere (unter der deutschen Fahne) gezogen und installiert.

Mit den Platzhaltern ist definitiv so, ich schicke Dir mal meinen gezippten Job. Da kannst Du mal unten in dem Testfeld bei den Filtern probieren.

Leider klappt das auch nicht wenn ich mich an die Anleitung halte. Schau doch bitte mal ob ich da etwas in dem Job falsch eingestellt habe. Wie geschrieben soll eigentlich alles was an 7ter Stelle ein "E" hat inklusieve aller Unterordner in ein zip gepackt werden.
Das mitspeichern des Pfades ist aber wichtig damit ich bei Bedarf auch alles wieder an den Ursprungspfad kopieren kann.

VG
Michael

Title: Re: Problem beim Zippen
Post by Dirk on May 4th, 2010 at 3:39pm
Hallo Micha,

ich bin nicht Gerd - macht aber nix.

Beende die Aufgabe, dann rechtsklick-> Aufgabe sichern. Sende mir die zip-Datei andie Adresse, die Du im Footer dieses Postings siehst. Bitte auch noch einen Screenshot des aufgeklappten Verzeichnisbaumes dazu.

WatchDirectory Forum » Powered by YaBB 2.5.2!
YaBB Forum Software © 2000-2017. All Rights Reserved.