WatchDirectory home page
WatchDirectory Startseite (Deutsche Version)
Site WatchDirectory (Français)
  Welcome, Guest. Please Login or Register
YaBB - Yet another Bulletin Board
   
  HomeHelpSearchLoginRegister  
 
Page Index Toggle Pages: 1
Service starts and immediately stops (Read 3278 times)
Terry
YaBB Newbies
*
Offline


I love YaBB 1G - SP1!

Posts: 2
Service starts and immediately stops
Mar 20th, 2005 at 10:19pm
 
I tried the demo version for a number of weeks and loved it.  I had been running as a service.  I then bought 5 users licenses.  Went to the "buy" GUI and put in the new key and it said OK.  Then my problems began.  Note that the user name was also different with the 5 user lic.

I could not get the service to start.  I would start and immediately stop.  So I uninstalled the demo version and reinstalled the system.  Same problem.  I have two service configurations set up and they also worked on the demo version????

Terry
Back to top
 
 
IP Logged
 
Terry
YaBB Newbies
*
Offline


I love YaBB 1G - SP1!

Posts: 2
Re: Service starts and immediately stops
Reply #1 - Mar 20th, 2005 at 10:31pm
 
Well...seems I solved the problem.  I had installed the new version into WatchDirector1 not WatchDirectory after I unzipped the file.  I found this out when I had given up on the service and tried to run without the service.  An error occured that indicated the log file was looking for the WatchDirectory not the WatchDirectory1.  I first renamed the directory but that didn't work.  I then copied the directory to WatchDirectory and kept the initial installed Watchdirectory1.  The service started right up.

Terry
Back to top
 
 
IP Logged
 
Gert
YaBB Administrator
*****
Offline



Posts: 2233
The Netherlands
Re: Service starts and immediately stops
Reply #2 - Mar 21st, 2005 at 5:31am
 
Quote:
I could not get the service to start.  I would start and immediately stop.

When you (try to) run watchDirectory as a service, and it has troubles starting up, it will write to the Windows Event log (control panel -> administrative tools -> event viewer) the reason why it could not start.
Not sure what was happening here, would be interesting to see what was written to the log.

Quote:
I had installed the new version into WatchDirector1 not WatchDirectory

The current watchDirectory version has troubles with these 'side-by-side' installs. I guess what happened is that the Service (watchDirectoryService.exe) was running from one directory (watchDirectory), while the 'real' watchDirectory program ran from the other directory. That would get several things mixed up.

Glad you got things working now.

Gert
Back to top
 

Gert Rijs - gert (at) gdpsoftware (dot) com
Blog: http://blog-en.gdpsoftware.com/
End Alzheimer's: http://www.alz.org&&...
WWW WWW GdPSoftware  
IP Logged
 
Page Index Toggle Pages: 1