WatchDirectory home page
WatchDirectory Startseite (Deutsche Version)
Site WatchDirectory (Français)
  Welcome, Guest. Please Login or Register
YaBB - Yet another Bulletin Board
   
  HomeHelpSearchLoginRegister  
 
Page Index Toggle Pages: 1
wdPostMan issue/question (Read 7416 times)
bgeoghan
YaBB Newbies
*
Offline


I love YaBB 1G - SP1!

Posts: 12
wdPostMan issue/question
Sep 26th, 2005 at 6:34pm
 
Gert,

I am hoping that you can help.  I am monitoring 2 network directories.  One network directory is a satandard c: drive and works correctly.  The other is a Network Attached Storage (NAS) share.  The NAS share is where I  having an issue.

Shortly after starting wdPostMan I receive the following error:

Can process \\amerinas\POD\40NCDC051537032.pdf? Error Code: 53
Description: The network path was not found.

Date/Time: 9/26/2005 10:16:40 AM
Computer: ~

The above error is obtained when I have the monitoring set to any of the available choices(Polling, normal, fast).  The error(s) occur w/o the actual job running, just wdPostMan.

I can view this file with no issue from the computer where wdPostMan is running (logged in with the proper credentials).  I changed how wdPostMan service was running – I changed the user logon to same credentials I use when I normally login to the server where wdPostMan is running.  This did not change the behavior.

These errors just continue until I stop the wdPostman service (I setup the email notification).  Again, these errors seem to be isolated to the wdPostMan process, as neither of my two jobs is running when these errors occur. 

Any help would be greatly appreciated.

Thanks,

Bill
Back to top
 
 
IP Logged
 
Gert
YaBB Administrator
*****
Offline



Posts: 2233
The Netherlands
Re: wdPostMan issue/question
Reply #1 - Sep 26th, 2005 at 6:44pm
 
The messages are from your real watchDirectory tasks (wdPostMan doesn't create messages, it just sends them for the watchDirectory tasks).

watchDirectory "gives" wdPostMan work by writing messages to the directory
Code:
C:\Documents and Settings\All Users\Application Data\watchDirectory\System.Mail\Out 


wdPostMan noticed the new file and sends it as an email.
If sending the email fails it will be placed in the directory
Code:
C:\Documents and Settings\All Users\Application Data\watchDirectory\System.Mail\fail 


And from there, the sending will be retried a few times (depending on your settings).

There are probably several *.wdmail files inside your "System.Mail\out" and/or "System.Mail\fail" directory written by previous runs of your tasks that are still waiting to be sent...

Does that make any sense?

Gert

Back to top
 

Gert Rijs - gert (at) gdpsoftware (dot) com
Blog: http://blog-en.gdpsoftware.com/
End Alzheimer's: http://www.alz.org&&...
WWW WWW GdPSoftware  
IP Logged
 
Gert
YaBB Administrator
*****
Offline



Posts: 2233
The Netherlands
Re: wdPostMan issue/question
Reply #2 - Sep 26th, 2005 at 6:49pm
 
Quote:
These errors just continue until I stop the wdPostman service (I setup the email notification).  Again, these errors seem to be isolated to the wdPostMan process, as neither of my two jobs is running when these errors occur. 


Maybe the wdPostMan service can not delete the files after processing (sending)??!? Some security issue (can happen if you "play" with the userid settings of the postman service).

When the postman service runs "default", it will be running as LocalSystem and should be allowed (as far as I know) to read/move/delete files from all users. If you change the credentials to another user, the PostMan service may not be allowed to delete the message files it has already sent.

Gert
Back to top
 

Gert Rijs - gert (at) gdpsoftware (dot) com
Blog: http://blog-en.gdpsoftware.com/
End Alzheimer's: http://www.alz.org&&...
WWW WWW GdPSoftware  
IP Logged
 
bgeoghan
YaBB Newbies
*
Offline


I love YaBB 1G - SP1!

Posts: 12
Re: wdPostMan issue/question
Reply #3 - Sep 26th, 2005 at 8:49pm
 
Gert,

I see now, the wdPostMan service is literally the service that sends emails.  I deleted all the out files and the message stopped.  I must have had over 1000 messages queued up Embarrassed

What I did to correct all the issues was as follows :

1 - setup an entirely new user in the NAS (via the NAS web interface)
2 - then setup the same user on the machine where my WD jos runs, granting it sufficient privledges to run
3 - ran the job as a service as that new user

The WD job now runs great.

I truly appreciate your fast turnaround on this. 

BTW - to answer your last question, I did not change the logon user for the wdPostMan service until after all the emails.  The email issue was jus the 'pent up' demand.  I suspect that we had issues with our SMTP server and they just all went all out at the same time (1000 +).

Thanks,

Bill
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1