WatchDirectory home page
WatchDirectory Startseite (Deutsche Version)
Site WatchDirectory (Français)
  Welcome, Guest. Please Login or Register
YaBB - Yet another Bulletin Board
   
  HomeHelpSearchLoginRegister  
 
Page Index Toggle Pages: 1
Filter events not completely processing (Read 2841 times)
rkneale
YaBB Newbies
*
Offline



Posts: 2
Filter events not completely processing
May 2nd, 2007 at 6:16pm
 
hi, WD folks -

I've been trying out watchDirectory at work for the past couple of weeks and I'm quite pleased; we're planning on buying the professional version for the task we need if I can get this problem figured out.

Basically, I'm watching a rather large directory for any changes, and having WD email me every 3 hours with the changes in that directory.  There are some files I want to exclude, though, such as any temp files, so I added two filters, one for filename starts with ~, and one for filename ending with 'tmp'.  For the past week, that's been working fine, but yesterday I started getting those files in my reports again.  I can't figure out what's going on.   Huh 

Help.... thanks!
Back to top
 
 
IP Logged
 
Gert
YaBB Administrator
*****
Offline



Posts: 2238
The Netherlands
Re: Filter events not completely processing
Reply #1 - May 3rd, 2007 at 6:29am
 
Strange.
I guess you already checked if the filters are still correct?

Can you send me the following 2 files (please ZIP them):

<task directory>\<yourtaskname>.config
<task directory>\<yourtaskname>\history.db

<task directory>: press CTRL+9 inside the watchDirectory Control Center to explore this directory
<yourtaskname>: the name of your task

so I can have a look?

Gert
Back to top
 

Gert Rijs - gert (at) gdpsoftware (dot) com
Blog: http://blog-en.gdpsoftware.com/
End Alzheimer's: http://www.alz.org&&...
WWW WWW GdPSoftware  
IP Logged
 
rkneale
YaBB Newbies
*
Offline



Posts: 2
Re: Filter events not completely processing
Reply #2 - May 3rd, 2007 at 5:33pm
 
hi Gert,

Just emailed you the zip file...

Yes, it's strange!  According to the filter test, they are still correct - when I put in a ~ or a 'tmp' I get a file evaluates as true and will not be processed result... just can't figure out why they're showing up in my report.  Hope the files give you some insight!

Ruth
Back to top
 
 
IP Logged
 
Page Index Toggle Pages: 1