WatchDirectory home page
WatchDirectory Startseite (Deutsche Version)
Site WatchDirectory (Français)
  Welcome, Guest. Please Login or Register
YaBB - Yet another Bulletin Board
   
  HomeHelpSearchLoginRegister  
 
Page Index Toggle Pages: 1
Suddenly getting errors ? (Read 5715 times)
GarethHall
YaBB Newbies
*
Offline



Posts: 12
Suddenly getting errors ?
Dec 18th, 2007 at 10:36pm
 
Been running fine for months now without any problems, all of a sudden I am getting these errors, doesn't seem to be anything on the forum about them, any ideas ?

TIA.

SyncPoint ThreadID: 0x3F0 -- EXCEPTION!

Date/Time: 19/12/2007 7:33:04 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR PIDI - HEAP CORRUPT - -4 - BADNODE PIDI - HEAP CORRUPT - -4 - BADNODE
Date/Time: 19/12/2007 7:33:04 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR CopiesRunning - HEAP CORRUPT - -4...
CopiesRunning - HEAP CORRUPT - -4 - BADNODE
Date/Time: 19/12/2007 7:33:04 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR PauseResume - HEAP CORRUPT - -4 -...
PauseResume - HEAP CORRUPT - -4 - BADNODE
Date/Time: 19/12/2007 7:33:04 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR WaitForQuit - HEAP CORRUPT - -4 -...
WaitForQuit - HEAP CORRUPT - -4 - BADNODE
Date/Time: 19/12/2007 7:33:04 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR RenameHelper - HEAP CORRUPT - -4 ...
RenameHelper - HEAP CORRUPT - -4 - BADNODE
Date/Time: 19/12/2007 7:33:04 AM
Computer: WDEL0006
Back to top
 
 
IP Logged
 
Gert
YaBB Administrator
*****
Offline



Posts: 2224
The Netherlands
Re: Suddenly getting errors ?
Reply #1 - Dec 19th, 2007 at 8:27am
 
Hello Gareth,

The "heap" is (un)allocated memory. WatchDirectory performs some sanity-checks while it is running, and may give these errors if there is something wrong.

I have seen these heap corruption errors only on one computer, and that computer turned out to have a faulty memory chip. Not saying that it is the case here, but....
Did you try a "fresh boot" of the computer?

Gert
Back to top
 

Gert Rijs - gert (at) gdpsoftware (dot) com
Blog: http://blog-en.gdpsoftware.com/
End Alzheimer's: http://www.alz.org&&...
WWW WWW GdPSoftware  
IP Logged
 
GarethHall
YaBB Newbies
*
Offline



Posts: 12
Re: Suddenly getting errors ?
Reply #2 - Dec 19th, 2007 at 11:14pm
 
Yes, tried a reboot, happens as soon as windows comes up, gives the error and then the task that is the problem stops running. Anytime I start the task again it just stops Sad
Back to top
 
 
IP Logged
 
Gert
YaBB Administrator
*****
Offline



Posts: 2224
The Netherlands
Re: Suddenly getting errors ?
Reply #3 - Dec 20th, 2007 at 10:39am
 
Reading between your words, it sounds like you have multiple tasks running? This one is the only task that has the problem? In that case we can probably rule out faulty memory.

Maybe the task's history database became corrupt... Can you try the following:

Create a new task (doesn't matter what it does), name it, for example, HELLO.
Make sure the HELLO and pdfchange tasks are not running
Select the menu "Tools -> Explore task directory" (this opens explorer in the directory where your task settings are stored)
open the sub-directory called HELLO, and copy the history.db file from that directory to the sub-directory pdfchange (overwrite the existing history.db)

if the pdfchange directory contains the following files, delete them:
history.db-journal
pid.txt
synchpoint.txt

Now try to start the pdfchange task again. (you can remove the HELLO task).

Gert
Back to top
 

Gert Rijs - gert (at) gdpsoftware (dot) com
Blog: http://blog-en.gdpsoftware.com/
End Alzheimer's: http://www.alz.org&&...
WWW WWW GdPSoftware  
IP Logged
 
GarethHall
YaBB Newbies
*
Offline



Posts: 12
Re: Suddenly getting errors ?
Reply #4 - Jan 7th, 2008 at 12:03am
 
Did the above suggestions, still there Sad

SyncPoint ThreadID: 0xE64 -- EXCEPTION!

Date/Time: 7/01/2008 8:59:44 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR WaitForQuit - HEAP CORRUPT - -4 -...
WaitForQuit - HEAP CORRUPT - -4 - BADNODE
Date/Time: 7/01/2008 8:59:44 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR CopiesRunning - HEAP CORRUPT - -4...
CopiesRunning - HEAP CORRUPT - -4 - BADNODE
Date/Time: 7/01/2008 8:59:44 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR RenameHelper - HEAP CORRUPT - -4 ...
RenameHelper - HEAP CORRUPT - -4 - BADNODE
Date/Time: 7/01/2008 8:59:44 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR PauseResume - HEAP CORRUPT - -4 -...
PauseResume - HEAP CORRUPT - -4 - BADNODE
Date/Time: 7/01/2008 8:59:44 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR TaskCaller - HEAP CORRUPT - -4 - ...
TaskCaller - HEAP CORRUPT - -4 - BADNODE
Date/Time: 7/01/2008 8:59:44 AM
Computer: WDEL0006


----------------------
[watchDirectory:pdfchange] ERROR PIDI - HEAP CORRUPT - -4 - BADNODE PIDI - HEAP CORRUPT - -4 - BADNODE
Date/Time: 7/01/2008 8:59:44 AM
Computer: WDEL0006
Back to top
 
 
IP Logged
 
Gert
YaBB Administrator
*****
Offline



Posts: 2224
The Netherlands
Re: Suddenly getting errors ?
Reply #5 - Jan 7th, 2008 at 2:00pm
 
Do you have multiple tasks running? This is the only one with this issue?

Can you create a new task with the same settings and try to run that? Do not "copy" the problem task as it could potentially copy the problems as well...

If that doesn't work can you email me the following 2 files (zip them please):

<task directory>\<yourtaskname>.config
<task directory>\<yourtaskname>\history.db

<task directory>: press CTRL+9 inside the watchDirectory Control Center to explore this directory
<yourtaskname>: the name of the problem task

Gert
Back to top
 

Gert Rijs - gert (at) gdpsoftware (dot) com
Blog: http://blog-en.gdpsoftware.com/
End Alzheimer's: http://www.alz.org&&...
WWW WWW GdPSoftware  
IP Logged
 
GarethHall
YaBB Newbies
*
Offline



Posts: 12
Re: Suddenly getting errors ?
Reply #6 - Jan 13th, 2008 at 11:22pm
 
I only have one task running apart from System Mail, postman service.

I have created a new task identical to the first, it now seems to be working fine, original task must have been corrupted.

Thanks

Back to top
 
 
IP Logged
 
Gert
YaBB Administrator
*****
Offline



Posts: 2224
The Netherlands
Re: Suddenly getting errors ?
Reply #7 - Jan 13th, 2008 at 11:26pm
 
Ah, great.
I would still be interested to see the original task settings, so I can improve WD to handle this problem better. So if you still have the original .config and .db file, please send them to me.

Gert
Back to top
 

Gert Rijs - gert (at) gdpsoftware (dot) com
Blog: http://blog-en.gdpsoftware.com/
End Alzheimer's: http://www.alz.org&&...
WWW WWW GdPSoftware  
IP Logged
 
Page Index Toggle Pages: 1